Archive for the ‘Uncategorized’ Category

Monday, July 20th, 2009

In other news I got eight Lincoln MkVII injectors, which are 234cc at 3.0 bar, to replace the 143cc at 2.5 bar (which is 170cc at 3.0bar) stock BMW injectors I have. All for free. Good thing my grandpa kept absolutely everything when he was still around.

Also I posted a want-ad for a speedometer cable on bmw2002faq and somebody replied – so $32 later I’ll soon have a speedometer cable again.

As far as the car goes, there’s a little bit of a rhythmic thump every once in a while, especially around hard right turns – I noticed when I was under the car before that the transmission was kicked over to the driver’s side a little bit, and while I’m not sure why I’ll be crawling under there with a prybar to see if I can get it to stay a little more true to the tunnel. Other than that – the car is absolutely fantastic. No problems with the transmission at all, save for a bit of a reluctant 2nd gear (which grinds a little when the box is cold) and having an overdrive is great on the freeway. The most noticeable improvement were those rear subframe bushings because the car rotates like crazy now, but not too much to make it totally uncontrollable [cough-911-cough]

I dug out my Palm V and loaded a couple of Megasquirt tuning/logging apps so we’ll see how useful that is compared to my laptop (which has a fairly weak battery) – anybody have a serial cable for a Palm V? The dock I have would be a little bit bulky for in-car tuning :\

Saturday, July 18th, 2009

So I found that my spare engine has a crank pulley that fits the trigger wheel perfectly. Unfortunately, it’s the worst (read: heaviest) type of pulley available – smog pump and AC with a balancer.

So I was thinking, since we have a lathe, what problems would I run into if I decided to just cut down the balancer part and maybe one of the pulley grooves?

Alternatively, I have the early, early single groove stamped pulley but the metal where the front main seal rides has been pretty heavily grooved. My thinking for that would be to mic the good metal to get the desired diameter, then run a bead around the grooved part, chuck it up in the lathe and turn it down until it’s just a little bit larger than the desired diameter. Since the surface of the part that the seal rides on is supposed to be incredibly smooth I was thinking of bringing it to a machine shop to have it polished like they would a crank.

Thoughts? Any machinists out there? 😛

Saturday, July 18th, 2009

quote:

Products
——————————————————
1 x MegaSquirt-I Programmable EFI System PCB3.0 – UnAssembled Kit (MS130-K) = $187.00
1 x PCBv3 and v2.2 — Relay Control ‘ModKit’ (VTEC, TVIS, Fans (mk-RelayCtrl) = $5.00
1 x 12′ MegaSquirt Wiring Harness (MS1 / MS2 Ready) (MSHarness12) = $65.00
1 x GM Open Element IAT Sensor with Pigtail (IATwPiggy) = $22.25
1 x Lead Bending Tool (T-LeadBend) = $5.50

Gronk build computer

Thursday, July 16th, 2009

I fooled around a little bit today, first I wanted to put the rear bumper guards back on so I had to do a little bit of work to get the rubber on. heh


The studs impregnated in the rubber bumpers rusted so they broke free of their bond and just spun around, so I had to improvise. I drilled a couple of holes in the bumper guard itself.


You can see the studs here, they obviously were longer but I drilled them out and die grinded them until they were flat.


Then I used a couple of sheet metal screws and just screwed them directly into the rubber.


I’m not sure if I like them on the car but they’re easy enough to remove if I get sick of them.


I remembered I had these sweet Carello driving lights that my dad used on his old Mercedes 240D and/or Diesel Rabbit and I noticed there were a few holes where the bumper guards would go in the front so I decided to see what they looked like. I might leave them where they are depending on how much of the headlight beams they actually interrupt.


The roughest syf0n shot in history


They’re pretty bright but right now they’re not wired up. I’ll try test wiring them tonight and get a few photos of them on.

Thursday, July 16th, 2009


I know that this looks like garbage but I was pretty frustrated at this point. Wired up the reverse lights, they worked for a little bit and then they went out. After checking the wiring and cleaning out the grease-filled terminals I found that the fuse was blown. Replaced it and only the right side light came on. Discovered after shorting the wires to the switch together that the other bulb’s base was just a little corroded. Then found out that one of the spade terminals going to the switch was cracked, and replaced it. After that neither light turned on so I’m pretty sure I now have a blown reverse light switch. :\


I got a distributor rotor from A1 Imports Autoworks in San Rafael, they do tons of cool 2002 projects and general maintenance. They had a real factory 2002 turbo and about 7 other ’02s there, a DeLorean and a few other cool cars in the shop.


Remember how my pertronix almost died? Yeah.


Retiming the car


Yay! Not quite a mountain road but the car moved here under its own power! The burning gear oil really wasn’t too bad, I didn’t want to risk messing up the paint on the header with brake cleaner so I didn’t clean it that way.

Things that don’t work:
-reverse lights
-speedometer (I was expecting this since I don’t have the right cable)

Things that do work:
-the transmission

I didn’t drive it too much tonight so I don’t know how it handles now with all those polyurethane parts but tomorrow I’ll update 🙂

Tuesday, July 14th, 2009


I said the other day that brakes were my least favorite thing to do. I forgot about putting the header in. It’s just big enough coming from the top or from the bottom that it’s infinitely frustrating!


Finally in and with the e30 318i heat shielded exhaust manifold gasket


In the great tradition of not leaving well enough alone, I decided to get the distributor seated the way it’s supposed to be. In doing this I found out that I’ll be needing a new rotor.


I can get about 15° of rotation moving it by hand so it’s probably a good idea to be patient and get a new one.


For the gearbox! I ended up making the biggest mess possible because like an idiot I didn’t fill the box until after I had put the header in.


This ought to smell great. The fill plug on the transmission is right above the collector of the header, so not only is it difficult to get to, but when the box is full it will drip gear oil all over one of the hottest areas of the exhaust with the greatest surface area of the system, all into places that can’t be wiped clean. It should smoke for a good 20 minutes. :V

Thingz 2 do: reverse light wiring, dizzy rotor

Sunday, July 12th, 2009

Most of the work I did yesterday didn’t look like much, mostly routing lines, torquing bolts, bleeding brakes + clutch, stuff like that. Here are the pictures of what I did:


Clutch hydraulics are in and the line is frighteningly close to the accelerator pedal but I moved it through its full range it didn’t hit anything.


Driveshaft and new guibo are in with new nylock nuts (finally)


Rear swaybar is back in


Used this piece of strut with some bolts sticking out to align the driveshaft. With the 2 bolts level on the rearward portion the deviance at the very front was only about 1/4″. I think that’s satisfactory.

I think at this point all I need to do are flush the differential and transmission, connect the reverse switch wires, and put the exhaust system back on. Then I’m 99% sure it will be drivable! Hopefully I’ll get that done tomorrow. 😀

Saturday, July 11th, 2009

I hardly got anything done today so here’s what I did yesterday but was too tired to post! It doesn’t really look like much which sucks because I felt like I spent all day on it


Rear subframe is in the car and good to go


Now onto those springs in the drums that I took out and was NOT looking forward to reinstalling… This picture has the hub on the trailing arm


But this one doesn’t. Thanks for this BMW


I cussed and yelled and struggled for a while but eventually, with the help of some vicegrips, needlenose pliers and an old flat blade screwdriver I was able to finally get the springs in.


Disconnected the axle in order to let the trailing arm drop all the way so I could install the springs. It’s much easier than using the spring compressor I have and trying to maneuver it into the wheel well


Oh and I picked up the driveshaft from the shop and… It fits! Almost perfectly with the diff adjusted to some random position. I’ll get everything else I need to done, bolt the driveshaft to the trans and pull the DS and differential forward to where they should be. Then I’ll tighten up all the rear end bolts.


Finally on the ground!


I still have a good amount of work to do including reinstalling the exhaust.

Today all I did was cut and drill the diagonal brace for the shift platform and then paint it. This gearbox feels far tighter than the 4-speed did and I can’t wait to drive it.

Tomorrow: Install new guibo, attach driveshaft, align driveshaft, position differential+tighten it, bellhousing bolts, maybe install header and exhaust? I don’t think I’m going to get around to doing the steering stuff but it shouldn’t be too much of a nightmare even with the header in the car.

Wednesday, July 8th, 2009


Axles and hardware after spending some quality time in the parts washer – I know it’s going to get dirty again in no time but I hate putting parts in and then being all greasy afterwards! I should probably get new Nylock nuts for the bolts but there are 24 of them so we’ll see how much they cost.


Differential bolted to the subframe, axles bolted to the diff…


I went ahead and added some trailing arms to the package and bolted the stub axles to the halfshafts


Artsy overexposed photo of the braided line on the driver’s side with the passenger’s side flex line off in the distance


Differential hanger/carrier/doohickey


By the way, those polyurethane bushings are replacing this. These hold up the back of the subframe, can you say sloppy rear end? heh


On another note, anybody know where I could get a shock gaiter/dust boot for a Bilstein HD? This one got a little bit smushed when I installed it wrong one time, and I can’t run without it since there’s an integral washer at the top of it. Used or new, doesn’t matter.

Tomorrow: subframe should be all prepped to go in, picking up the driveshaft, car will be rollable for the first time in a week. Maybe I’ll go nuts and pull off the steering drag link to change idler arm bushings and adjust the steering box.

Tuesday, July 7th, 2009


New M10x1.5 nylok nuts on the diff carrier


The diff, while still incredibly rusty, is now mostly devoid of the grime that was stuck on it earlier. How something can be rusty and have so much grease on it I have no idea. While cleaning it I found the breather hole, but unfortunately I had already got some water in it so I think I’m going to play it safe and drain it.


Scraping the dirt off the trailing arms and the pile it left behind. I’ll pressure wash it tomorrow.


Cleaned, tapped and/or died all the hardware for the rear subframe. I got some M12 nylok nuts but they’re M12x1.75 instead of the M12x1.5 that I need. So I’ll buy that maybe tomorrow.

Tomorrow: Stainless braided flex hoses, reassembly, maybe steering guibo?